Zurück   EffizienzGurus Forum > Software & mehr > Anwendungsprogramme > Programmierecke

Hinweise

JDBC+Oracle Resultset immer leer

Dieses Thema wurde 0 mal beantwortet und 2985 x angesehen.

Antwort
 
Themen-Optionen
Alt 22.01.2009, 17:58   #1
Fachmann
 
Registriert seit: 02.2007
Beiträge: 659
Standard JDBC+Oracle Resultset immer leer

Hi, ich versuche gerde erstmalig eine Verbindung zu ener Oracle Datenbank aufzubauen. Leider ist das ResultSet scheinbar immer leer. Jedenfalls geht er in die While Schleife nicht einmal rein. Führe ich die SQL Abfrage direkt in Oracle aus bekomme ich 10 Ergebnisse. In der Tabelle ist also was drin. Vielleicht weiss ja einer von euch Rat.

Code:
import java.sql.*;
public class connect {

	Connection conn;
	Statement stmt;
	public connect() {
	try {
		Class.forName("oracle.jdbc.driver.OracleDriver");
		conn = DriverManager.getConnection(
		"jdbc:oracle:thin:@localhost:1521:xe",
		"system","meinpass");
		System.out.println("...done");
	}
	catch (Exception ex){
		System.out.println("*** Exception:\n"+ex);
		ex.printStackTrace();
	}
	}
	
	public static void main(String args[])
	{
		try{
			connect db = new connect();
			db.stmt = db.conn.createStatement(ResultSet.TYPE_SCROLL_INSENSITIVE,ResultSet.CONCUR_READ_ONLY);
			ResultSet rs = db.stmt.executeQuery("select * from student");
			while(rs.next())
			{
				System.out.println(rs.getString(1) + ", " + rs.getString(2));
			}
			db.stmt.close();
		}
		catch(Exception ex){
			System.out.println("*** Exception:\n"+ex);
			ex.printStackTrace();
		}
		
	}
	
}

Geändert von KaiZen (22.01.2009 um 18:01 Uhr)
KaiZen ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are aus
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Vista: Bleibt nach der Installation von SP1 immer beim Booten stehen Darkwing Duck Betriebssysteme 5 11.09.2008 20:38
PC stürzt immer nach dem Hochfahren ab House-Baby Overclocking 1 10.09.2008 16:35
Akkus lagern: Aufgeladen oder leer? dracoonpit Consumer Electronics 8 07.09.2008 08:55
Netgear Smart Wizard stürzt immer ab Bastian2k5 Netzwerk, Sicherheit & Co 0 11.10.2007 22:02
Bildschirm erkennt Signal nicht immer :( [CH]IlvlAIRA Grafikkarten 8 17.06.2007 18:52


Alle Zeitangaben in WEZ +1. Es ist jetzt 17:37 Uhr.


Powered by vBulletin® Version 3.7.5 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.2.0

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41